Help with setting up a mail server

Erik Norgaard norgaard at
Tue Jul 20 16:15:12 UTC 2010

On 20/07/10 15.26, Aryeh M. Friedman wrote:
> I am a consultant and was retained by my client to setup qmail or exim
> on a VPS running 8.0-STABLE (i386). After setting up the DNS (A record
> and MX record) we have been unable to send or receive mail. The client
> has/had a working script for installing qmail on 7.1-STABLE but it
> seems to not work on 8.0-STABLE. They are using the same VPS provider
> who this 7.1-STABLE install script worked under. I have tried
> everything I can think of to make it work including asking obvious
> questions on -questions at .

First, as everybody else: If you are not satisfied with the default 
sendmail the most popular alternative seems to be postfix, it will 
probably be much easier for you to get help with postfix should the 
problem turn out to be the mail configuration.

When you modify your DNS it may take a while before the changes 
propagate, depending on the TTL setting in your zone configuration.

You can check if the mail server is running and can deliver mail locally 
by, on the mail server, do

   $ telnet localhost 25

You can then type in manually the smtp commands, see rfc 2821. If you 
can, then it may be a dns problem.

Next, can you send out? You may well be able to send out while you can't 
receive mail from external servers for local delivery. If this is the 
case, either your DNS is wrong or the changes has not yet propagated.

If you can't, check the error messages, if there is some dns related 
error look in /etc/resolv.conf to see if you use the right dns server, 
do some dns queries to check that it works. If you use your own dns 
server, check the named.conf and verify any forwarders entries.

If you can't receive mail from external servers for local delivery, but 
local delivery works - locally. Try from a different host to telnet to 
your mail server using the ip address,

   $ telnet mail-server-ip 25

If this works, maybe your dns changes has not yet propagated.

If more time than the TTL has passed and your dns does not resolve 
correctly, check that you updated the serial number in the zone file, it 
must be incremented every time you make a modification or the changes 
won't propagate to dns slaves.

If you can't connect, maybe you have a firewall issue.

This I think should get you started trouble shooting.

> I informed the client that the task is likely beyond me capabilities
> but I would help recruit someone who would be able to do it at a
> reasonable fee paid to them

If you found my advice useful, please donate a reasonable fee to the 
FreeBSD project, I am still endepted for the great effort of all the 
people involved in the project.

BR, Erik

More information about the freebsd-questions mailing list