libSM Configure Script Failure

Chris Maness chris at chrismaness.com
Wed Jul 14 19:37:13 UTC 2010


On Wed, Jul 14, 2010 at 12:29 PM, Greg Larkin <glarkin at freebsd.org> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Chris Maness wrote:
>> What would cause a configure script to fail?  See output bellow.
>>
>> Chris Maness
>> (909) 223-9179
>> http://www.chrismaness.com
>>
>
> Hi Chris,
>
> Since we've been conversing privately for a bit, I went back to your
> original message and found something that might benefit you and the list
> as a whole, if someone else runs into this problem.
>
> I see this error message:
>
> ...
> ...
> configure.ac:21: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...):
> suspicious cache-id, must contain _cv_ to be cached
> ../../lib/autoconf/general.m4:1973: AC_CACHE_VAL is expanded from...
> ../../lib/autoconf/general.m4:1993: AC_CACHE_CHECK is expanded from...
> /usr/local/share/aclocal/libtool15.m4:615: AC_LIBTOOL_COMPILER_OPTION is
> expanded from...
> /usr/local/share/aclocal/libtool15.m4:4815: AC_LIBTOOL_PROG_COMPILER_PIC
> is expanded from...
> /usr/local/share/aclocal/libtool15.m4:2651: _LT_AC_LANG_C_CONFIG is
> expanded from...
> ...
> ...
>
> Notice the pathname "/usr/local/share/aclocal/libtool15.m4".  You
> emailed me privately with the list of your installed packages, and you
> have libtool-2.2.6b installed.  This libtool15.m4 file seems to conflict
> with that version of libtool, so please post the output of this command:
>
> pkg_which /usr/local/share/aclocal/libtool15.m4
>
> Thank you,
> Greg

It just returned a ?.  So does that mean that it is not referenced by
any package?  If it is not, can I just delete it?  Also, this seems to
be the issue with libX11.  Someone gave me a similar response for
libX11 on the X11 list.  However, they have not gotten back to me on
what I should do with it.

Thanks,
Chris Maness


More information about the freebsd-questions mailing list