Dell SAS5/IR

Grant Peel gpeel at
Wed Jul 14 12:30:09 UTC 2010

>> Hi all,
>> I was attempiting to restage a server last night to no avail. It is a 
>> Dell
>> 860 with a LSI SAS (Dell SAS5/SI) controller.
>> This was happening when I was dumping the filesystems from a USB memory
>> stick (da1s1) to the hard drive (Seagate 76 GIG SAS - da0s1).
>> Can anyone tell me if they have seen this before? or if it is a Hard disk
>> problem, or a problem with the SAS controller, or is it a FreeBSD 
>> problem?
>> I ahve donwloaded the latest SAS firmware and installed it, ran the Dell 
>> 32
>> Bit diags,  ran the drive diagnostics, etc etc and everything passes with 
>> no
>> errors.
>> I simply cant install dumps, or install a fresh copy of freebsd.
>> I have snapshots of what the console iis showing, but in a nutshell:
>> (da0:mpt:0:0:0:0): Synchonize cahce failed, status =0x4a, scsi status = 
>> 0x0
>> (da0:mpt:0:0:0:0): removing device entry
>> Device /da0s1e went missing before all of the data could be written to 
>> it,
>> expect data loss
>> I have snapshots if anyone wants me to send them off list.
>> Any possible resalutions ?
> The way I read your problem is that you are dumping a slice with 
> partitions
> to another slice correct?
> I don't think that works, dump(1) works on the filesystem level, so a
> partition by partition dump and restore is needed.
> -- 
> Adam Vande More
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"


Sorry I should have been clearer in my original post.

I had made dumps from one machine from each individual file system

/        (dev/da0s1a)
/var        (dev/da0s1d)
/usr        (/dev/da0s1e)
/home        (/dev/da0s1f)

Then, on a different machine, was dumping them using the LIVE FS CD boot 
disk, to it's primary drive that was pre fdisk'd and the filesystems 

The root, var filesystem restored fine, but, as I said, the usr filesystem 
keep crapping out with the errors mentioned.

I even get the same error when trying to actually install freebsd from CD, 
from scratch.

Yesterday, I ran every diagnostic available to the system (Dell 32 Bit 
Diags, on board controller diags, etc) and they all passed with no errors.

I have seen some scuttlebutt white googling, about the SAS5/IR buuffer 
problems, but have not seen a resolution yet.


More information about the freebsd-questions mailing list