Help needed : FreeBSD 8.1 / xorg / xf86-video-intel / dell400

Henri-Pierre Charles hpcharles at
Tue Jul 13 12:04:30 UTC 2010

Hello, I've a dell d400 laptop quite old but still usefull. I've upgraded to
8.1-RC2 which seem ok. It was perfectly functionnal with FreeBSD 8.0
and the freebsd-8.0-release packages.

My usual way to upgrade packages is to "pkg_delete -a" && pkg_add -r a list
of my usual softwares which come from ports/i386/i386/packages-8.1-release/
which contain xf86-video-intel-2.7.1_3 && xorg-7.5

It's impossible to have a graphical output

(1) Using video-intel the system hang immediately without any message

I've also tried to add :
      Option     "DRI" "off"                  # [<bool>]
      Option     "NoAccel" "on"               # [<bool>]
 in my /etc/X11/xorg.conf Device section : still hang

I've try to patch  i830_display.c:i830_crtc_load_lut as suggested in another
thread, the system does not hang but has a black screen

(2) Using video-vesa X fail with a message :
 "(EE) VESA(0): No valid modes"
 "(EE) Screen(s) found, but none have a usable configuration."

I've put all the possible information here :
- pciconf -lv
- xorg.conf
- Xorg.0.log for intel driver, intel patched driver, vesa driver .

I've tried to modify my initial xorg.conf without any success. Is
there a solution,
(even with a not accelerated solution) or am I obliged to downgrade to
8.0 to keep
FreeBSD or install a modern ubuntu (troll inside :-) ? Any idea or clue ?



More information about the freebsd-questions mailing list