Samba gives "invalid PT_PHDR" after upgrading from 7.2-RELEASE to 7.3-RELEASE

David Brodbeck gull at
Wed Jul 7 06:27:22 UTC 2010

On Sat, July 3, 2010 2:49 pm, David Brodbeck wrote:
> Today I upgraded my system from FreeBSD 7.2-RELEASE to FreeBSD 7.3-
> RELEASE using freebsd-update. Samba no longer runs.  I get the
> following error messages:
> Starting nmbd.
> /libexec/ /usr/local/sbin/nmbd: invalid PT_PHDR
> Starting smbd.
> /libexec/ /usr/local/sbin/smbd: invalid PT_PHDR
> My upgrade sequence was to run 'freebsd-update upgrade -r 7.3-RELEASE'
> and 'freebsd-update install', followed by a reboot, then 'freebsd-
> update install' again, followed by a second reboot.
> I tried rebuilding the Samba port, thinking maybe it was an ABI
> change, but it still doesn't work.  Can someone point me in the right
> direction?

Today I tried using "portupgrade -R -f samba34" to rebuild samba and all
of its dependencies, but I'm still getting the same error. I'm a little
surprised that a minor version upgrade broke this so thoroughly.  I went
back over the release notes to see if I missed any obvious caveats about
upgrading, but if I did, I'm not seeing it.

More information about the freebsd-questions mailing list