Weird build errors only on 3rd core of quad core CPU

Pieter de Goeje pieter at
Wed Jan 27 22:54:26 UTC 2010

I am suspecting a broken CPU, but am not sure.

These commands:
cd /usr/ports/sysutils/hal
cpuset -c -l 2 make

Will always result in errors, for example this one:

gmake: *** No rule to make target `@MAINTAINER_MODE_TRUE@', needed by 
`'.  Stop.
*** Error code 1

Sometimes the error occurs in a different place. When I check the input files, 
they are indeed broken. Gcc stops because of syntax errors for example.

The configure process always completes, but apparently it creates broken 
files. When I run make on any other core, it always completes successfully:
cpuset -c -l 0,1,3 make

I've checked with script that the output of the build process is exactly the 
same, up until the error occurs. I've also tried to run cpuburn on that core, 
but it didn't find any problem. It's really weird that system is otherwise 
very stable.

What do you guys think the problem is?

CPU is AMD Athlon II X4 620. Running FreeBSD 8-STABLE/amd64. I've also 
tried -CURRENT, but it didn't help.



More information about the freebsd-questions mailing list