"Invalid partition table" after installation

Fbsd1 fbsd1 at a1poweruser.com
Fri Jan 22 12:17:28 UTC 2010

John wrote:
> On Thu, Jan 21, 2010 at 10:25:26PM +0800, Fbsd1 wrote:
>> John wrote:
>>> On Thu, Jan 21, 2010 at 04:38:22PM +0800, Fbsd1 wrote:
>>>> John wrote:
>>>>> I've tried the "modern BIOS" geometry and the "255 head" geometry.
>>>>> I've ensured that the first slice (boot slice) is smaller than 1.5
>>>>> Gb.  I've tried to figure out what the BIOS thinks the geometry
>>>>> is, but it doesn't seem to want to tell me.  At least, I can't find
>>>>> it in the BIOS menu anywhere.  When I boot from the CD-ROM with
>>>>> the 255 head geometry, though, it complains about the disk geometry,
>>>>> saying 16h,63s != 255h,63s or something like that - it flies by
>>>>> pretty fast (is there a way to go back and see that from the CD-ROM
>>>>> "boot only" boot?).
>>>>> I'm using the "Standard" boot manager, and the entire disk is devoted
>>>>> to FreeBSD.
>>>>> System
>>>>> BIOS version  PT84510A.86A.2004.P05
>>>>> Processor Type: Intel Pentium 4
>>>>> Processor speed: 2.20Ghz
>>>>> Memory: 512Mb
>>>>> Disk: Primary IDE Master ST380021A (Seagate Barracuda ATA IV 80Gb)
>>>>> Primary IDE Slave: IOMega ZIP 250
>>>>> Secondary IDE Master: Sony CD-RW CRX19 (what I boot from to install)
>>>>> Secondary IDE Slave: DVD-ROM DDU1621
>>>>> Boot sequence:
>>>>> 1) ATAPI CD-ROM
>>>>> 2) Hard Drive
>>>>> 3) "Removable Dev."
>>>>> "Modern BIOS" geometry: 155061/16/63 for ad0
>>>>> "calculated" geometry: 9729/255/63 for ad0
>>>>> ad0s1 start=63, size=2875572
>>>>> ad0s2 start=2875635, size=10217340
>>>>> ad0s3 start=13092975, size=143203410
>>>>> unus  start=156296384, size=5103
>>>>> ad0s1a / 384Mb
>>>>> ad0s1d /usr 1Gb
>>>>> ad0s2b SWAP 1Gb
>>>>> ad0s2d /tmp 384Mb
>>>>> ad0s2e /var 512Mb
>>>>> ad0s2f /var/mail 2Gb
>>>>> ad0s2g /usr/ports 1Gb
>>>>> ad0s3d /home/mysql 4Gb
>>>>> ad0s3e /home 50Gb
>>>>> ad0s3f /usr/src 3Gb
>>>>> ad0s3g /usr/obj 3Gb
>>>>> ad0s3h /extra 8483Mb
>>>>> Suggestions, please?  I'm making zero headway right now. :(
>>>> What version of FreeBSD are you running????
>>> Well, yes, I suppose that would be a good bit of information!
>>> What I'm *TRYING* to run is 8.0.  It seems to install successfully
>>> (of course - after doing all that), but then when I try to boot
>>> from the hard drive, I see an otherwise-blank screen that says:
>>> Invalid partition table
>>> and that's as far as it goes!
>>>> _______________________________________________
>>>> freebsd-questions at freebsd.org mailing list
>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>>>> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"
>> There are reports of this sort of thing caused by 8.0 fdisk when doing a 
>> install from scratch over a hard drive that all ready has an older 
>> version of Freebsd installed on it.
>> The solution is to force the scratching of the MBR on the disk first 
>> before running sysinstall fdisk.
>> Boot a LiveFS CD, then at a root prompt do:
>> sysctl kern.geom.debugflags=16  and:
>> dd if=/dev/zero of=/dev/adx oseek=1 bs=512 count=1
>> where x equals your drive number.
> OK.  I did exactly that.  I confirmed that the second 512 bytes were zero
> by doing a dd if/dev/ad0 bs=512 count=2 | od -c
> and everything from 001000 through 002000 was zero.
> But I still got "Invalid partition table" after the installation.
> I guess I should set up one of my other systems as a local mirror.
> I've done the installation so many time already, and it looks like
> I'm not done yet!

On the 8.0 fdisk/MBR subject.
Doing dd if=/dev/zero of=/dev/adx oseek=1 bs=512 count=1 was the
solution from another post to the list with subject 'SunFire X2100
fails'. Here is another post that gives more details

It seems in 8.0 gpart was introduced and a change was made to fdisk to
support its sector o mbr format. 8.0 fdisk and disklabel are now broken.

Searching the list archives may shed more light on your problem.

More information about the freebsd-questions mailing list