Trying to build 8.0 Headless Installation Disk

Martin McCormick martin at
Wed Jan 13 16:21:43 UTC 2010

	I started to use the same strategy that worked in 6.x
but it is not working right now.

	I obtained8.0-RELEASE-i386-disc1.iso and did:
mkdir 8.0serial
tar xf 8.0-RELEASE-i386-disc1.iso

	This produced a read-write file system that appears sane
in that it seems to be large enough, but not larger than a
standard CDROM.

	The boot directory has loader.conf in it but there is no
reference to any console.

	I added the following:

#add by martin

	The CDROM burner is on a Linux system so I used tar to
copy the 8.0serial file system over to the Linux system and then:

mkisofs -l -R -q . |cdrecord -dev=/dev/hdc -

	This produces a CD that looks fine in that you can mount
it, see all the files, etc.

	The CD does not boot and the system continues to boot as
if there was no CD in the drive.

	I did burn an unmodified image to a CDROM and the system
did hang, waiting for keyboard input so that ISO image does work
but I need the serial console to come up on boot as we will be
running it remotely. This has worked in the past when necessary,
but it appears something changed between FreeBSD6.3 and 8.0 and
I must be doing something wrong now.

	Has anybody gotten an 8.0 CD to come up on the serial

	One thing that has changed between 6.3 and 8.0 is that
the tar application does not get confused. In 6.3, there were a
couple of files that caused an "out of order" error but the 8.0
CD produced no errors at all.

	Thank you for your help.

Martin McCormick WB5AGZ  Stillwater, OK 
Systems Engineer
OSU Information Technology Department Telecommunications Services Group

More information about the freebsd-questions mailing list