cannot install apache22 on FBSD 8.0

PJ af.gourmet at
Wed Jan 13 15:45:03 UTC 2010

On 1/13/2010 4:09 AM, Matthew Seaman wrote:
> PJ wrote:
>> Gentlemen,
>> I am absolutely stupefied by apache22, php5, php5-extensions and
>> phpmysql refusing to be updated or installed
>> I did manage to do one installation on a freshly upgraded box from 7.2
>> to 8.0 but with very frustrating and time consuming efforts. I still
>> don't know how I managed, but it seems to work, for the moment anyway.
>> Could someone explain to me why there is a problem with apache22, php5
>> and the rest - when doing an upgrade from 7.2 to 8.0.
>> I followed the instructions in the handbood to the letter and both times
>> there is a problem.
>> Am I doing something that is not evident in the instructions. Even the
>> apache site states very clearly that and update is about as simple as
>> could be.
>> The long list of errors when installing apache seem to deal with a lot
>> of undeclared stuff (first use in this function) for a lot of uldap
>> stuff like cache, connection etc. etc.
>> How does one deal with this as there seems to be nothing on google.
>> TIA
> You're installing quite a complex interconnected group of ports there,
> and
> it can go wrong in any number of new and exciting ways.  We can't tell
> exactly
> what has gone wrong from what you tell us -- but it's almost certainly a
> problem fairly high up the dependency tree which is screwing things up
> for
> all of the ports lower down you're having trouble with.
> As a general strategy for making this work, probably the most effective
> route is 'back to square one.'  Rip out everything that apache, php etc.
> depend on, and start again from scratch.  This includes all options
> settings
> for those ports under /var/db/ports/.
> When reinstalling a group of interconnected ports like this, I find it
> beneficial to sort out all of the OPTIONS settings over the whole
> dependency
> tree before trying to compile anything.  One of the unfortunate
> characteristics
> of the way OPTIONS processing works at the moment is that changing an
> option
> somewhere can add or remove other ports from the dependency tree, and
> those in their turn may have their own OPTIONS settings, but those
> OPTIONS are not processed in that pass.  There are patches to correct
> that behaviour in PR ports/141641 but until that or something like it
> is committed, the trick is
> to run 'make config-recursive' repeatedly, until you no longer get
> presented with any of the blue OPTIONS dialogues.
> Some ports may not give you an OPTIONS dialogue but still have
> configuration
> settings you can tweak by setting make(1) variables.  In this case, I
> recommend
> preserving your settings by adding them to /etc/make.conf.  Changing a
> setting like this can affect the dependency tree in exactly the same
> way as changing an
> option, so re-running 'make config-recursive' /yet again/ is a good idea.
> I wrote a piece about this earlier in the context of reinstalling all
> ports as
> part of the process of upgrading 7.2 -> 8.0, which you might like to
> refer to:
> Note: there's a fairly tricky interplay between www/apache22 and
> devel/apr
> which only affects you if you enable the APR_FROM_PORTS option in the
> apache22
> OPTIONS dialogue -- both www/apache22 and devel/apr can be configured
> to add dependencies on all sorts of fairly large software groups
> (Berkeley DB, MySQL, LDAP, PostgreSQL ...) and to toggle threading
> support.  Empirically I've come to the conclusion that if you're
> compiling against devel/apr, then devel/apr has to include matching
> support for all the software groups enabled in the apache22 options,
> or building apache22 will fall over in a twisty mess of dependencies,
> all alike.  However, you pretty much cannot get the OPTIONS settings
> right in one pass of 'make config-recursive' starting from the
> www/apache22 directory.  You can avoid some trouble by *not* enabling
> the APR_FROM_PORTS option -- which is the default, but loses some
> flexibility
> if you're going to be rebuilding Apache or any 3rd party apache
> modules quite
> a bit.
>     Cheers,
>     Matthew
Thanks for the input.
There was no way that apache22 was going to install with the apr. I
tried everything imaginable and referred to your suggestions.
Finally, I removed apr, removed the configuration files from the /work
directory, redid config without apr and did config-recursive.
Much to my surprise, it worked... now to install php5 and php5
extensions and try it all out.

More information about the freebsd-questions mailing list