Fwd: Booting from ZFS raidz

Anselm Strauss amsibamsi at gmail.com
Fri Jan 8 15:59:03 UTC 2010

Sorry, forgot the list ...

---------- Forwarded message ----------
From: Anselm Strauss <amsibamsi at gmail.com>
Date: Fri, Jan 8, 2010 at 4:50 PM
Subject: Re: Booting from ZFS raidz
To: Sergiy Suprun <sergiy.suprun at gmail.com>

I've done some experiments with the 8.0 stable branch and the head branch
from SVN. I just recompiled /boot/loader but didn't have any luck. The
version from the stable branch gives me the exact same error, the head
version fails with a new error. Doesn't seem this is really ready at the
moment. I think I'll go with a separate mirror pool for now.


On Wed, Jan 6, 2010 at 9:43 PM, Sergiy Suprun <sergiy.suprun at gmail.com>wrote:

> Hi.
> Some time ago I follow instruction from this wiki
> http://wiki.freebsd.org/RootOnZFS and I had a problem like yours.
> After some experiments I build loader from CURRENT, and boot fine from
> raidz2 zpool. I don't know, may be now this code avialable in 8-STABLE.
> On Wed, Jan 6, 2010 at 20:25, Anselm Strauss <amsibamsi at gmail.com> wrote:
>> Hi,
>> I'm experimenting with a ZFS only system and booting from it in
>> VirtualBox. Thanks to various mails and forum posts from the net I have a
>> working scenario with booting from a ZFS mirror. However, I can't get the
>> thing to work with raidz with the exactly same setup, except that the pool
>> is now raidz instead of mirror and there is one more disk. I feel sure I
>> have all the stuff with partitioning, boot loader installation, etc. right.
>> I tested this with version 8.0-RELEASE on 64bit.
>> Now, before I go into detailed explaining, is raidz really supported? I
>> always get the following error after it says "FreeBSD/i386 bootstrap loader,
>> Revision 1.1":
>> ZFS: i/o error - all block copies unavailable
>> ZFS: can't read MOS object directory
>> (repeats a lot)
>> Can't find root filesystem - giving up
>> can't load 'kernel'
>> I think the "MOS" message comes from zfs_mount_root() in
>> /usr/src/sys/boot/zfs/zfsimpl.c. I asume that is the point when /boot/loader
>> has been loaded and now wants to load the kernel into memory. After that
>> error I'm in the loader prompt. When I try to load any file I always get the
>> same error as above.
>> Anyone any ideas?
>> Thanks,
>> Anselm_______________________________________________
>> freebsd-questions at freebsd.org mailing list
>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>> To unsubscribe, send any mail to "
>> freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list