FreeBSD ipv6 rc.conf settings issue

Steve Bertrand steve at
Thu Jan 7 14:57:06 UTC 2010

Bogdan Webb wrote:
> I'm having problems with the /etc/rc.conf setup of a ipv6 tunnel on my
> FreeBSD 7.2-RELEASE-p6
> It`s a particular issue on the ipv6_defaultrouter config, it jost does not
> work...
> Upon network and routing restart ipv6 is enabled the gif interface are given
> ip's and everything but the defaultrouter does not.
> Researching a bit i found some say that gif1 sould work and tried both
> ipv6_defaultrouter="-interface gif1"
> and
> ipv6_defaultrouter="2001:0470:1f0a:d40::1"

This issue is not limited to gif interfaces...

I've had this exact same problem on ALL of my FreeBSD hosts for, well,
since ever.

No matter what I've tried, if a box reboots, I must manually enter in
the default IPv6 router.

Even on IPv6-only hosts, the default gateway does not take upon reboot.

I'm up for figuring this issue out today, if nobody else has a solution
for you.

Let me know. If you're interested, I'll fire up a couple of hosts that
we can use and just continuously reboot if necessary :)


More information about the freebsd-questions mailing list