gianrico.lamura at gianrico.lamura at
Mon Jan 4 12:27:09 UTC 2010

Dear Sir,

to install MATLAB i have followed striclty what FreeBSD doc suggests (even
if this doc is not updateed and contains erros) @

To avoid the "SSE2" problem I followed:

to run succesfully the installation. But, at the end of the installation,
when I have to activate the licence, the systems diplay an error that is
explained in the /tem/aws.log file as :

"(Jan 04, 2010 12:58:48)There was an unexpected exception.  See the log
file (/tmp/aws.log) for more details.
(Jan 04, 2010 12:58:56)java.lang.UnsatisfiedLinkError:
/usr/compat/linux/usr/local/matlab/bin/glnx86/ cannot handle TLS data " (**)

and the system stops!!

I tried to run anyway the matlab script but an erro occurred for the sam
reason of SSE2 check. Thus I corrected it by following :

the program starts with the licence request but the same problem as in (**)
still diplays.

I have searched for several days in the net for a solution but I found
nothing. I'm desperate because I need matlab. I have the licence. I run it
before on the same laptop. I changed to FreeBsd since Ubuntu was too bad
for my Philips Freevents X59. But now I do not know how to solve this

Please, could you help me before I will forced to change another time the
operating system?

thank you in advance


More information about the freebsd-questions mailing list