Problem with a sound card

Piotr Lukawski plukawski at
Fri Feb 26 16:15:19 UTC 2010

Please help me with a problem.

I installed FreeBSD 7.2-RELEASE-p4 FreeBSD 7.2-RELEASE-p4 #0: Fri Oct  2
12:21:39 UTC 2009
root at

on Cassiopea Fiva MPC-205E ( ) with
build in sound card "AC-Link connected sound chip (16-bit stereo PCM)"

Then I tried "kldload snd_driver" and the driver was recognised as:

casiopea# cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 32bit 2007061600/i386)
Installed devices:
pcm0: <Acer Labs M5451> at io 0x1000 irq 10 kld snd_t4dwave [GIANT]
(1p:1v/1r:1v channels duplex default)

but... still no sound

then I enabled the driver in /boot/defaults/loader.conf

snd_t4dwave_load="YES"          # t4dwave

the driver is loading properly, but ... still no sound

Following the suggestion from
I've put these into my /etc/sysctl.conf:
> >
> > hw.snd.maxautovchans=10
> > hw.snd.pcm0.vchans=4

still no sound

if I try

casiopea# mpg123 puszek.mp3

I get:

High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
        version 1.10.0; written and copyright by Michael Hipp and others
        free software (LGPL/GPL) without any warranty but with best wishes

Playing MPEG stream 1 of 1: puszek.mp3 ...
MPEG 1.0 layer III, 320 kbit/s, 44100 Hz joint-stereo

but still no sound.

Please help to solve it, I have no more idea what I can do with.

Thanks in advance,
Take care,

More information about the freebsd-questions mailing list