Printing via USB Port

Bill Tillman btillman99 at
Fri Feb 26 14:49:04 UTC 2010

--- On Fri, 2/26/10, C. P. Ghost <cpghost at> wrote:

From: C. P. Ghost <cpghost at>
Subject: Re: Printing via USB Port
To: "Bill Tillman" <btillman99 at>
Cc: freebsd-questions at
Date: Friday, February 26, 2010, 3:44 AM

On Fri, Feb 26, 2010 at 2:28 AM, Bill Tillman <btillman99 at> wrote:
> I tried cups but I could not get it to work even though it found the printer on
> ulpt0:.

You may have the permissions-related problem described here:


Cordula's Web.
Thanks, that's some very useful information but alas it did not help me. After further testing here is what I can say:
1. The ugen device does not show up in dmesg.

2. The ulpt0 device does show up and it clearly identifies the Brother-HL-2040 printer on the other end of the USB cable.
# dmesg | grep ulpt
ulpt0: <Brother HL-2040 series, class 0/0, rev 2.00/1.00, addr 2> on uhub0
ulpt0: using bi-directional mode

3, I edited /etc/devfs.rules as instructed and restarted the service. I then restarted cupsd. Nothing changed. I cold booted the entire setup but still cupd web interface will not find the printer. If I manually enter the printer and then install a ppd file for it I still get nothing to print.
This printer worked fine when I was using lpd and a parallel port. Also the apsfilter port is broken which makes it more difficult for a novice like me to get the correct setting for it with lpr method. So I was really looking forward to getting cupsd working this time round.
Any additional advice would be appreciated.


More information about the freebsd-questions mailing list