kde4/python26 and pth help. [SOLVED]

Jimmie James jimmiejaz at gmail.com
Thu Feb 25 20:36:34 UTC 2010

On 02/25/10 00:12, Dima Panov wrote:
> On Thursday 25 February 2010 14:47:08 Jimmie James wrote:
>> On 02/24/10 23:28, Adam Vande More wrote:
>>>> On Wed, Feb 24, 2010 at 12:11 PM, Jimmie James<jimmiejaz at gmail.com
>>>> <mailto:jimmiejaz at gmail.com>>  wrote:
>>>>      On a freshly installed 8-STABLE box (4 days old) and up to date
>>>>      ports, KDE4 will not install for me, always the same errors. I've
>>>>      even removed all ports and reinstalled from scratch and hit the same
>>>>      errors. I have no /etc/make.conf. I'm at a loss here, I have no idea
>>>>      why this is happening.
>>>>      I even did a  portupgrade -fRru python26  and tried portmaster, and
>>>>      plain old make in the ports that fail.
>>> As for you error, I don't know what happened.  I used to see those
>>> happen on a massive upgrade when using portupgrade.  I recommend
>>> portmaster.  Somehow python didn't get installed correctly because
>>> /usr/local/include/python2.6/Python.h should exist if python is
>>> correctly installed.
>>> --
>>> Adam Vande More
>> Thanks for the reply,
>> Haven't got around to testing X yet, but on 7.2-STABLE it works fine, so
>> I'm not too worried about that. It's the python and pth errors that are
>> killing me.
>>    /usr/local/include/python2.6/Python.h  is there, seems correctly
>> installed.  Even installing with portmaster and plain old make install
>> it _still_ hits those errors of not finding the headers.
>> checking for /usr/local/bin/python2.6 version... 2.6
>> checking for /usr/local/bin/python2.6 platform... freebsd8
>> checking for /usr/local/bin/python2.6 script directory...
>> ${prefix}/lib/python2.
>> 6/site-packages
>> checking for /usr/local/bin/python2.6 extension module directory...
>> ${exec_prefix}/lib/python2.6/site-packages
>> checking for headers required to compile python extensions... not found
>> configure: error: Python headers not found
>> As well as /usr/bin/ld: cannot find -lpth
> Doh. Please, don't build python againist pth library, it's broken, and off by default.

That got it, rebuilding python without pth made almost everything build. 
  A few parts of KDE4 refuse to build because of "ImportError: no module 
named sipconfig"  which I'm looking into now.

Thanks for the help!

More information about the freebsd-questions mailing list