cvsnt (server) crashes on all operations after portupgrade

Steve Franks bahamasfranks at
Sat Feb 20 00:01:06 UTC 2010

> You wrote that inetd invokes cvsnt.  Can you post the relevant
> inetd.conf line in case that has anything to do with it?

That I haven't messed with:

cvspserver	stream	tcp	nowait	root	/usr/local/bin/cvsnt	cvsnt authserver

> Also, you mentioned that you csup'd the 8.0-RELEASE source tree, and you
> are now running -p2.  That seems fine to me, since you are tracking a
> release branch + bug fixes.
> Can you verify that this sequence of events occurred?
> 1. Installed some version of 8.0-RELEASE and cvsnt 2.5.03.something.
> cvsnt worked fine.
> 2. Installed 8.0-RELEASE-p2 (new kernel + userland) sources, rebuilt
> kernel and userland and rebooted. cvsnt 2.5.03.something continued to
> work fine.
> 3. Portupgraded cvsnt to 2.5.04.something and now it crashes upon any
> operation.
> Let me know if the steps occurred in a different order than that.

Nope, that's exactly how I remembered it.

I tried running "sudo cvsnt authserver" from a shell after disabling
inetd, but it never appeared to listen to the port, it took it's input
from stdin, detected an absence of a vlid cvs client when I hit enter,
and exited normally.

All this is hopefully moot.  Largely due to cvsnt's move towards more
commercial interference (default win clients now have a yahoo-like tag
in each commit string, etc.), and a total lack of any response on the
cvsnt mailing list, if I can get cvs2svn to dump a git fast-import
file (like it supposedly can), I'm gonna have my source trees on
bazaar by monday (famous last words).


More information about the freebsd-questions mailing list