The Atheros 9285 patch on 8.0-stable

James Colannino james at
Sun Feb 7 08:38:27 UTC 2010

Hey everyone,

I have an Asus EEE PC 1005HA, which has an Atheros 9285 wireless 
chipset.  I discovered that Rui Paulo wrote a driver, and put up a patch 
for the 8.0 stable kernel here:

It seems to have worked for some people.  After patching and 
re-compiling my kernel, it did manage to detect the device on my 
machine, but unfortunately, I'm unable to scan for networks or associate 
with my network.  Here's what happens:

The machine boots, and I see the ath0 interface when I run ifconfig.  I 
then run the command 'ifconfig wlan0 create wlandev ath0' and 
successfully create wlan0.  However, when I run the command 'ifconfig 
wlan0 scan', the command doesn't seem to do anything, and I eventually 
have to CTRL-C it.

Has anybody else had this problem?  Is it a known issue?  Maybe I'm 
doing something wrong?  It was mentioned that testers were needed for 
this driver, and I'd love to help out if possible.  If anybody wants me 
to send any additional information, just let me know.

Thanks so much everyone!


More information about the freebsd-questions mailing list