cpio misunderstanding?

Carl Johnson carlj at peak.org
Sun Dec 26 23:08:32 UTC 2010

Polytropon <freebsd at edvax.de> writes:

> On Sun, 26 Dec 2010 11:30:59 -0800, David Brodbeck <gull at gull.us> wrote:
>> On Fri, Dec 24, 2010 at 4:57 PM, Joe Kraft <jvk-list at thekrafts.org> wrote:
>> > OK, now I know what's going on.  I just don't know why.  The immutable flag
>> > was set on all these files, if you clear it cpio will happily copy them to
>> > the new directory.
>> Does cpio attempt to preserve flags?  Since the error is "could not
>> create," I'm wondering if it's trying to set the same flags on the
>> copy of the file and failing to do so.
> I'm not sure about that - "man cpio" doesn't give a hint
> about flags. On the other hand, tar's -p option does keep
> the file mode (permissions), flags and maybe ACLs intact.
> I've tried "info cpio" ouch! ouch!, but that's not a
> continuous manual that allows easy searching for strings. :-(
> Some search in the /usr/src/bin subtree for the "chflags"
> call revealed that it is used by the chflags binary, cp,
> mv and rm commands, but no hint it is involved directly
> in cpio.

I had done some testing for flag support out of curiosity, and found
that only cp -p, bsdtar and dump support them.  Cpio, afio, gnutar,
gnucp and pax do not support them.  I also tested extended attributes
(used for ACLs?), and only bsdtar and dump worked for them.  Those
results were for usf, and generally didn't transfer to zfs at all or
probably other file systems.

Carl Johnson		carlj at peak.org

More information about the freebsd-questions mailing list