printing from inside Linux firefox

Dan Strick mla_strick at
Sat Dec 4 03:49:22 UTC 2010

I am running FreeBSD release 8.1.  I normally run a Linux Firefox
(currently version 3.5.15) because I need the flash plugin
(/usr/ports/www/linux-f10-flashplugin10).  I also need to print web pages
on occasion but the Linux Firefox does not recognize the printers attached
to my system.  It writes warning/error messages like this in the window
from which I ran the Firefox program:
	(firefox-bin:77065): Gtk-WARNING **: cannot open shared object file: No such file or directory

If I copy the missing library (from Fedora 10 Linux) into /compat/linux,
Firefox complains about another missing library.  If I give it more
libraries until it shuts up, it still does not find my printers.  I
speculated that cups requires additional configuration, so I created the
file /compat/linux/etc/cups/pinters.conf with a <DefaultPrinter ps0>
entry, but Firefox still won't recognize my printer and it produces
no warning/error messages that might give me a hint.

Obviously, I don't know what I am doing.  Can this be made to work?

I tried /usr/ports/www/firefox which installs as firefox3, a native
FreeBSD Firefox program.  It will print via lpr, but It won't
do flash.  I tried the flashplugin-mozilla port, but it just causes a
segmentation violation when I visit a page with flash items.
(Oddly enough, if I install linux-f10-flashplugin10 in a recent
version of Linux Firefox, it seems to fail in the same way.)

I tried printing to a file, but both the Linux and FreeBSD Firefox
programs create slightly strange postscript and pdf files which seem
to display correctly via the ghostscript and acroread programs but
won't print correctly on my postscript printer (a Brother HL-1270N).
I tried Linux Opera.  It fails just like the Linux Firefox.
This is actually a serious problem.  There are sometimes when I just
*have* to be able to save a postscript image (e.g. a map) and print
it later.

My sister tells me that I should be using MS Windows because that always
works correctly.  I don't know how to prove her wrong.


Dan Strick

More information about the freebsd-questions mailing list