USB Thumb Drive

Chris Brennan xaero at
Wed Dec 1 20:10:50 UTC 2010

Thanks all for the feedback, problem solved, details below.

Bruce -> "/dev/ad0s1" did the trick ... I was in such a hurry, I forgot to
actually look further, I was in a hurry and got impatient :P. "file -s
/dev/DEVICE" is a nice little trick, gonna have to tuck this one away for
another rainy day when I am stuck. The drive is ntfs, I formatted it that
way (I lost nearly 8gb of the 32gb capasity because of fat32).

[root at BlackDragon [~]# file -s /dev/da0s1
/dev/da0s1: x86 boot sector, code offset 0x52, OEM-ID "NTFS    ",
sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255,
hidden sectors 2048, dos < 4.0 BootSector (0x0)
[root at BlackDragon [~]# mount | grep thumb
/dev/da0s1 on /mnt/thumb (ntfs, local)
[root at BlackDragon [~]#

Jerry -> I kinda like the idea of exFAT but I don't put much stock in it
(yet). It is by far not a tried-and-true filesystem yet. And since M$ has
there hands in it, I doubt we'll see legit F/OSS drivers for it anytime

Jerry McAllister -> your fstab entry is my next step, thanks for the
reminder though :D

Ryan -> As I was saying to Jerry, I don't think we'll see reliable exFAT
drivers for the *nix world anytime soon :( It's sad really. M$ might
actually get something right in exFAT and it becomes a viable, scalable
alternative to NTFS.

More information about the freebsd-questions mailing list