wvstreaams + wvdial on FreeBSD 8.1 AMD 64

Antonio Olivares olivares14031 at gmail.com
Mon Aug 30 02:58:04 UTC 2010

Dear FreeBSD users,

I have run out of ideas to troubleshoot a difficult task:

get wvstreams and wvdial to work on FreeBSD 8.1.

I have tried without success to get the code to compile and I
encounter the following error:

./CXX -c utils/strcrypt
utils/strcrypt.cc:3:21: warning: crypt.h: No such file or directory
./CXX -c utils/verstring
./CXX -c utils/wvargs  -Iargp
./CXX -c utils/wvassert
./CXX -c utils/wvbase64
./CXX -c utils/wvcrash
./CXX -c utils/wvdiriter
./CXX -c utils/wvglob
./CXX -c utils/wvglobdiriter
./CXX -c utils/wvgzip
./CXX -c utils/wvhex
./CXX -c utils/wvmagiccircle
./CXX -c utils/wvmatrix
./CXX -c utils/wvpam
./CXX -c utils/wvrateadjust
./CXX -c utils/wvserialize
./CXX -c utils/wvshmzone
./CXX -c utils/wvstringtable
./CXX -c utils/wvsubproc
./CXX -c utils/wvsubprocqueue
./CXX -c utils/wvsystem
./CXX -c utils/wvtest
./CXX -c utils/wvtr1
./CXX -c utils/wvuid
./CXX -c utils/wvwordwrap
linking libwvutils.so...
/usr/bin/ld: argp/libargp.a(argp-help.o): relocation R_X86_64_32 can
not be used when making a shared object; recompile with -fPIC
argp/libargp.a: could not read symbols: Bad value
gmake: *** [libwvutils.so] Error 1
[olivares@ ~/Downloads/wvstreams-4.6.1]$

I applied the patches suggested here:


See the following threads for reference in case this is needed.


and a nice person, Laura, has helpred tremendously, but still can't
get past that error.
She encouraged me to ask, but I was hesistant to do so.  I have gotten
help with LaTeX/TeX issues and with autologin in with both KDE and in
XFCE and I appreciate the help I have gotten.  I tried downloading the
i386 version of 8.1-RELEASE and the special XFCE variant but downloads
got corrupted and md5 did not match so I gave up.  Tried it about 3
times and same result :(

What should I try or do to get this going?

In case anyone out there wonders, FreeBSD 8.1 does not have kppp by
default.  I need a dialer to be able to use my FreeBSD box to connect
to outside world.  To use this machine, I have Slax/Slax-Remix LiveCD
to connect but I would really like to use FreeBSD since it has been a
long time since I was able to connect from a FreeBSD box at home
(FreeBSD 6.X).

Thank you in advance for advice/suggestions/comments in this matter.



More information about the freebsd-questions mailing list