ISC-DHCP6 does not send replies

Indexer indexer at
Mon Aug 30 01:05:30 UTC 2010

Hash: SHA1

> It's different, yes.  That could be due to running DHCP6 -- after all,
> the daemon has to have some way of receiving all the DHCP traffic to the
> various site- and link- local addresses.  You can test that by turning
> off dhcpd and checking the routing table with it not running.  If the
> route doesn't disappear, try disabling dhcpd in /etc/rc.conf, rebooting
> and then see if that route is still present.  Either way, re-enable
> dhcpd in rc.conf and re-start the daemon: if the route appears then it's
> required by dhcpd and everything looks to be in order.

I removed this route, and it did not reappear when i restarted the DHCP6 server. It also did not affect the situation, i still get no leases.

> Ah.  Yes, this might cause you problems.  Possibly.  If Internode DHCP6
> has been configured as authoritative for your address range and if the
> query packets from your client can reach Internode's DHCP6 server then
> you probably will have trouble.  I shouldn't think its likely though --
> your client's DHCP6 initial queries will be to find a server on the same
> network segment, and to reach the Internode servers it would have to hop
> through your gateway machine, which is your DHCP6 server anyhow.

Well, it seems that the packets are all being sent to my gateway, not internode.

> If your network prefix is dynamically assigned, then I don't think there
> is a way to have a DHCP6 server be a DHCP6 client as well, and pass on
> the prefixes it has obtained dynamically.  BICBW.  If your ISPs policy
> is actually to assign you a particular prefix permanently rather than
> give you one out of some dynamically assigned pool, then it's worth a
> try using a static configuration on your gateway machine -- I believe
> you said this was a test setup to see if it could be rolled out on a
> customer network?  Should be fine to try static configuration like that
> for a limited time even supposing it's all dynamically assigned.

I tried, but the moment i turned off dhcp6c, i lost ipv6 connectivity, so no go sadly. 

Well, now i have a server that listens properly, but when my client sends it solicits, it dosen't pick them up at all. might be time to start playing with wireshark and tcpdump I guess. 

> 	Cheers,
> 	Matthew
> -- 
> Dr Matthew J Seaman MA, D.Phil.                   7 Priory Courtyard
>                                                  Flat 3
> PGP:     Ramsgate
> JID: matthew at               Kent, CT11 9PW

William Brown

Version: GnuPG/MacGPG2 v2.0.14 (Darwin)


More information about the freebsd-questions mailing list