serious (for me) Xorg 7.5 mouse/kbd problem in 8.1-STABLE

William Bulley web at
Wed Aug 25 12:05:28 UTC 2010

For years I have run Open-Motif on FreeBSD without issue.

I use a USB keyboard and a USB three button mouse attached to a Dell
Optiplex 960.  This combination has worked fine for the past year.

This week I upgraded from 8.0-STABLE circa January 2010 to 8.1-STABLE.
I do this by doing a buildworld/installworld sequence after csup-ing
stable-supfile and rebooting.  In this case I also pkg_deleted all of
my ports and am rebuilding them from source.  Building Xorg is one of
the very first ports I attempt since I prefer to work in xterms not
virtual terminals.

This upgrade moved me from Xorg 7.3 to Xorg 7.5, but Open-Motif stayed
the same - open-motif-2.2.3_6 - it hasn't changed in years.

After building Xorg, as root, I ran the "Xorg -configure" command to
generate my file.  Since a working /etc/X11/xorg.conf
file was still around after the upgrade from 8.0-STABLE/Xorg 7.3, I
felt no need to change anything in that file (later file comparisons
confirmed that nothing had changed).

My only relevant additions to /etc/X11/xorg.conf are these:

   Section "ServerFlags"
        Option  "AutoAddDevices" "off"
        Option  "DontZap" "false"

In my /etc/rc.conf file I have dbus and hald enabled, and that has
not changed since the beginning of 2010 after the confusion abated.

As a normal user, I start Xorg using /usr/local/bin/xinit as always.
I have several xterms configured in my ~/.xinitrc file.  All those
came up in the correct location and state.  I was able to open those
that started in iconic mode.  In an open/raised xterm I could enter
carriage returns and see my shell prompt move down the window.  But
when I tried to close/minimize an open/raised xterm, things failed.

I use the following keyboard/mouse combination (configured in my
.mwmrc file) to close (minimize) an xterm (and other applications):

   Shift   <Btn3Click>     window          f.minimize

This is also unchanged for some years.  This particular setting has
no bearing on the problem I came across yesterday.  I merely state
it for the record.  However, this configuration triggers the "bug".

The problem is as soon as I use that Shift/Btn3Click combination,
my arrow cursor disappears, then I cannot move to or select other
xterms - I am frozen, or locked, into the xterm I was trying to
close/minimize.  All I can do at this point is to kill(1) the
/usr/local/bin/xinit command to return to the virtual terminal
where I launched my Xorg session.

I am now reluctantly using the good old /usr/local/bin/twm which
is always built when Xorg is built from source.  I am at a loss
as to what to look for next.  I suspect Xorg, or the keyboard and
mouse driver, not the video driver, that came with.  It might be
a problem with hald(8), but again, I don't know how to debug this.

Any help with this very odd bug would be greatly appreciated.



William Bulley                     Email: web at

72 characters width template ----------------------------------------->|

More information about the freebsd-questions mailing list