How to configure ppp connection

Polytropon freebsd at
Mon Aug 23 19:03:36 UTC 2010

On Mon, 23 Aug 2010 20:05:32 +0200, Jakub Nowacki <poczta.jnowacki at> wrote:
> Hello!
> (First of all - forgive me my language, I'am form Poland)

Dobre. :-)

> I'am new in FreeBSD, but I have used Linux for a few year. 

As a first note, know that FreeBSD has *excellent* manpages. Know
the "apropos" and "man" commands, as they will always help you.

> I have got mobile modem: Huawei e1750c. As far as I know it is supported by 
> u3g driver. On Linux I use wvdial as a dialer, and there are no problems with 
> connection. On FreeBSD I just can't find propper ppp.conf, however I spend many 
> hours googling and trying some. 

You don't need google as a means of OS documentation. :-)

First, check /etc/ppp/ppp.conf which is the PPP configuration file.
Also, read "man ppp". I have used ppp.conf in the past for
dealing with PPPoE, and it worked without any problems.

> when i try to use "ppp default" and then "dial" i got:

You should define your own label for the connection in ppp.conf, e. g. the
name of the provider (doesn't have to be very verbose).

> # ppp default
> Warning: Bad label in /etc/ppp/ppp.conf (line 2) - missing colon
> Warning: Bad label in /etc/ppp/ppp.conf (line 2) - missing colon

Check those.

> ppp ON localhost> dial
> Warning: deflink: /dev/cuad1: Bad file descriptor
> Warning: deflink: /dev/cuad0: Bad file descriptor

PPP tries to access regular serial lines.

> Nothing happens, there is still no connection.

Sorry, I don't know enough about wireless network to be more specific,
but allow me this guess: If your connection requires PPPoE, you could
code something like this:

		set device PPPoE:<device>
		set authname <accountname>
		set authkey <password>
		set dial
		set login
		add default HISADDR

Then, "ppp blah" would be used for manual dialing. I'm not sure in how
far you are required to code AT dialing sequences.

> Some device nodes are created after I plug a modem. There is diff result
> of listed /dev pre and post pluging:
>  jakub at iac-deb:~$ diff /media/disk/pre_dev /media/disk/post_dev 
> 17a18
> > cd0
> 20a22,30
> > cuaU0.0
> > cuaU0.0.init
> > cuaU0.0.lock
> > cuaU0.1
> > cuaU0.1.init
> > cuaU0.1.lock
> > cuaU0.2
> > cuaU0.2.init
> > cuaU0.2.lock
> 23a34
> > da0
> 43a55,56
> > pass0
> > pass1
> 51a65,73
> > ttyU0.0
> > ttyU0.0.init
> > ttyU0.0.lock
> > ttyU0.1
> > ttyU0.1.init
> > ttyU0.1.lock
> > ttyU0.2
> > ttyU0.2.init
> > ttyU0.2.lock
> 77a100
> > ugen4.2
> -----------------------------------------------------------------------------------
> I would be very gratefull if You could help me to configure ppp.conf.

The ttyU* and cuaU* devices obviously belong to the modem.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list