clamav issues

Paul Macdonald paul at
Wed Aug 18 21:38:09 UTC 2010

Paul Macdonald wrote:
> Jerry wrote:
>> On Wed, 18 Aug 2010 12:25:21 +0100
>> Paul Macdonald <paul at> articulated:
>>> I'm having some problems with a clamav install and wondered if 
>>> anyone had any suggestions.
>>> As of a few days ago i noticed mail was getting rejected with 451
>>> retry codes.
>>> Checking the milters this appeared to be clamav, and removing this 
>>> milter fixed the problem.
>>> Afterwards, on tryign to fix the issue, i noticed that whilst clamd 
>>> started ok, it no longer stopped and just endlessly waited for the
>>> pid.
>>> I suspect this is related, as freshclam also was unable to notifuy
>>> clamd of updates.
>>> I've rebuilt clamav several times, mainly thinking that the first
>>> issue of why it wouldn;t stop was indictaive of it not responding to
>>> other requests ( milter , freshclam etc).
>>> I've moved the mail scanning onto another box, but would dearly like
>>> it to be working on this particular box.
>>> Where to start?  Suggestions welcomed!
>> Perhaps you could try the following - basically nuking clamav
>> 1) Stop Clamav/Freshclam and the milter if it is running.
>> 2) Run: pkg_delete -dfv clamav-0.96.2_1
>> 3) Remove or rename any config files of Clamav and it children. Also,
>> be sure to delete all of Clamav's definition files.
>> 4) Remove old Clamav log files
>> 5) Insure that any stale 'pid' files are deleted.
>> 6) cd to the clamav port and run "make config"
>> 7) Install the port and modify the Clamav/Freshclam/Clamilter config
>> files are needed.
>> 8 Either reboot or start manually all of the Clamav programs you
>> require. (I would recommend the reboot)
>> Good luck!
> thanks jerry, i'd pretty much done this, but followed these 
> instructions with those specific flasg and am still not able to use 
> the startup scripts to stop clamd after its started,
> The pid in /var/run/clamav/ is correct, but it never manages to stop 
> the daemon.
> I'm working from the assumption that i need to get it responding to 
> normal signals before trying any scanning ( i have tried adding it 
> back in to my sendmail config as get the same result as originally)
> I've got all the debugging on, and see nothing in logs when its told 
> to restart or sent any signals.
> Paul.
clamav now works fine when installing as a package over ftp, so thats a 
working although an unsatisying result..



Paul Macdonald 
Web and video hosting
t: 0131 5548070
m: 07534206249
e: paul at
40 Maritime Street

More information about the freebsd-questions mailing list