ZFS not usable on FreeBSD-8.1

Dick Hoogendijk dick at nagual.nl
Sun Aug 15 18:45:13 UTC 2010

  On 15-8-2010 3:10, George Hartzell wrote:
> Dick Hoogendijk writes:
>   >  And how do I make the partition precisely one block smaller than the
>   >  slic it lives in?
>   >  How do I know what the "blocksize" is?
>   >
>   >  >  Are you using explicit device names to add the disks to your pool?  If
>   >  >  so you'll gain robustness by using labels, either glabels as described
>   >  >  here:
>   >  >
>   >  >      http://submesa.com/data/bsd/zfs
>   >  >
>   >  >  or if you're in the gpt world then gpt labels as described in the
>   >  >  gpart commands illustrated here:
>   >  >
>   >  >      http://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/Mirror
>   >  I tried both methods. I had the disks as GPT labeld ones and slices by
>   >  sysinstall. None worked.
>   >  So it may be the one block difference. Please tell me how to do that.
>   >
> Just to be clear, I'm not refering to using GPT vs. MBR.  I'm
> suggesting that you when you use GPT you also label the partition with
> something like 'disk1' and then do something like (s/mirror/raidz/ as
> appropriate)
>    zpool create mirror foo /dev/gpt/disk1 /dev/gpt/disk2
> and *not*
>    zpool create mirror foo /dev/ad1p1 /dev/ad2p1
> If that's true you probably have something else going on.

Tried this today (again). Watched every step but zpool scrub ruined my 
zpool agian with the vdev.bad_label warning. It simply does not work. My 
1Tb drives do not waork with ZFS either, but at least these work with 

>     http://people.freebsd.org/~rse/mirror/
> The first script, just after the comment that starts:
>     place a PC MBR...
> uses fdisk to set up a slice that's one block smaller than the disk
> device (I was in{accurate,correct} in my description of the issue
> earlier when I attributed it to slice/partition interference).  You
> can see where it subtracts 1 from the size....
I learned a lot from the scripts. ;-) The drives work wonderful as a 
gmirror now.
My 500Gb drives won't however. they keep on giving cg); bad magic number.
Sysinstall won't newfs the drives. newfs -U /dev/gm1a (created with the 
script mentioned before does not work OK either. Always this unexplained 
message (cg0: bad magic number). I have NO CLUE whatsoever what can be 
the cause of this. Both drives can be formatted by Windows, Linux and 
lots of other utilities. They can not be formatted UFS2 for / by 

I would love to get some feedback about possible causes and/or 
solutions. right now those two 500Gb drives are useless. Spining around 
for no good. ;-)

More information about the freebsd-questions mailing list