ZFS not usable on FreeBSD-8.1

Dick Hoogendijk dick at nagual.nl
Sat Aug 14 19:57:53 UTC 2010

  On 14-8-2010 21:24, George Hartzell wrote:
> You haven't provided enough information for me to make a concrete
> suggestion, but this kind of thing often seems to boil down to
> something getting confused over slices and partitions when they both
> have the same extent (start->end) on disk.  This used to bite me in
> the gmirror world until I learned to make the partition one block
> smaller than the slice it lived in.

And how do I make the partition precisely one block smaller than the 
slic it lives in?
How do I know what the "blocksize" is?

> Are you using explicit device names to add the disks to your pool?  If
> so you'll gain robustness by using labels, either glabels as described
> here:
>     http://submesa.com/data/bsd/zfs
> or if you're in the gpt world then gpt labels as described in the
> gpart commands illustrated here:
>     http://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/Mirror
I tried both methods. I had the disks as GPT labeld ones and slices by 
sysinstall. None worked.
So it may be the one block difference. Please tell me how to do that.

More information about the freebsd-questions mailing list