Ifconfig (DHCP?) configures two IPs in one IF

Ashish SHUKLA ashish at FreeBSD.org
Thu Aug 5 20:34:30 UTC 2010

Guojun Jin writes:

> This problem comes  in 8.1-R. I have seen it before and  thought I filed a report but cannot find it.
> I found one (bin/21292) for ifconfig, but it was for two NICs with a same IP. Now is a reversed case
> One NIC has two IPs.

> Here is the description:

> Due to DHCP server down, I manually configured rl0 to for temporarily use.
> In the middle of working, DHCP came back and assigned  another IP on the rl0, now NIC is down
> due to two conflict IP addresses.

> rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
>         options=8<VLAN_MTU>
>         ether 00:40:f4:d1:23:9a
>         inet netmask 0xffffff00 broadcast
>         inet netmask 0xffffff00 broadcast
>         media: Ethernet autoselect (100baseTX <full-duplex>)
>         status: active
> plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> metric 0 mtu 1500

> I tried unplumb/delete rl0, but if does not  work.
> Before the bug can be fixed, is any way to fix the IP without rebooting the machine?

# ifconfig rl0 -alias

Above will cause to be removed from the interface. For details,
see ifconfig(1).

Ashish SHUKLA      | GPG: F682 CDCC 39DC 0FEA E116  20B6 C746 CFA9 E74F A4B0
freebsd.org!ashish | http://people.freebsd.org/~ashish/

“Few false ideas have more firmly gripped the minds of so many
intelligent men than the one that, if they just tried, they could
invent a cipher that no one could break.” (David Kahn, "The
Codebreakers", 1967)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 835 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20100805/b5adffa2/attachment.pgp

More information about the freebsd-questions mailing list