mounting UFS CD-ROMs

Noah Pratt npratt at
Thu Aug 5 01:04:09 UTC 2010

On Tue, Aug 3, 2010 at 8:44 PM, Michael Powell <nightrecon at> wrote:
> Noah Pratt wrote:
>> Hi,
>> I have a whole bunch of UFS CD-ROMs, but I'm unable to mount them on
>> my FreeBSD 8 system.
>> I thought it would be possible. From the FAQ:
>>     UFS CD-ROMs can be mounted directly on FreeBSD. Mounting disk
>> partitions from Digital UNIX and other systems that support UFS may be
>> more complex, depending on the details of the disk partitioning for
>> the operating system in question.
>> I tried the direct route:
>> 6930p# file -s /dev/acd0t01
>> /dev/acd0: Unix Fast File system [v1] (big-endian), last mounted on
>                                         ^^^^^^^^^^
> [snip]
>> 6930p# uname -a
>> FreeBSD 8.0-STABLE FreeBSD 8.0-STABLE #1: Mon May 17
>> 01:26:14 PDT 2010
>> root at  amd64
>> Am I missing something that ought to be obvious? [probable]
>> Is it no longer possible to mount UFS filesystems? [unlikely ;-) ]
>> Is there something specific about *this* UFS filesystem that prevents
>> it from working?
> I suspect maybe the disk was written using Solaris on SPARC, which is big-
> endian. Most PC architectures are little-endian.
> -Mike

Yes, the CDs were created in Solaris on SPARC. (I think it was a Sparc 10...)
And yes, my FreeBSD system is an Intel Core2Duo.

In Linux, copying the disc and mounting the disc image via loopback
worked great:
   ubuntu# cat /dev/cdrom > cd-image
   ubuntu# mount -t ufs -o ro,loop cd-image /mnt

It looks like NetBSD has a kernel build option FFS_EI, to enable
fsck_ffs -B to convert the byte order.
(I don't have a NetBSD system to test though.)

I even found a Windows program called R-Studio (
) that was able to recover data from these discs.

Can the filesystem's endianness be converted in FreeBSD?

Thanks a lot!


More information about the freebsd-questions mailing list