problems with hal in freebsd 7.2 i386

CmdLnKid cmdlnkid at
Wed Sep 30 21:41:40 UTC 2009

On Wed, 30 Sep 2009 16:36 -0000, chrisa wrote:

>> On Wed, 30 Sep 2009, chrisa at wrote:
>>>> My systems work well with hal. I find overall setup to be faster and
>>>> smoother(at this point in time) with hal enabled although there is much
>>>> adversity to it on this list.
>>>> Do you have xf86-input-mouse installed?
>>> I do have it installed. I'm going to try manual configuration to see if
>>> I
>>> can make it work.
>> If you can tell what graphics card you have, no doubt someone can
>> provide a sample.  I can come up with ones for ATI and Intel.
> It's a Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or something.
> Built-in to the motherboard. That's what Xorg autodetects, anyway, and it
> starts up and shows blackbox.
> I ran Xorg -configure and started it with the result, and
> that time the screen stayed black throughout. Odd.
>>> By the way, you find it faster and smoother with hal enabled? I recall
>>> reading an earlier thread about hal where some people found everything
>>> slower and less responsive. Interesting.
>> It turns out that hal plus a "disable hal" option makes things not work.
>> The opposite is probably also true.
> Interesting.
> Anyhow, I looked at my Xorg.0.log. I noticed a line saying it can't find
> any input devices, and relies upon hal to find them. Then I ran a ps -ax
> and found that hal isn't running, even though it should be, being set to
> start in rc.conf, along with dbus. So I started it, the startup script
> appeared to work, but hald still isn't running. Then I started dbus first,
> then hald, and they were both running, restarted X, and suddenly it works.
> I swear both were running last night when the mouse and keyboard input
> didn't work. They are, after all, set to start up at boot time. Also, the
> most recent Xorg.0.log contains the lines:
> (II) Cannot locate a core pointer device.
> (II) Cannot locate a core keyboard device.
> (II) The server relies on HAL to provide the list of input devices.
>        If no devices become available, reconfigure HAL or disable
> AllowEmptyInput.
> even though the mouse and keyboard both work now. To make sure that it was
> the most recent log file, I deleted all the Xorg logs, restarted it, and
> read the most recent one. And it still contains those lines with the
> working mouse and keyboard.
> Thanks, all, for your help. Now I only have TWO problems left!
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

Add the following to your X11 config and see what you come up with.

Section "ServerFlags"
         option  "AutoAddDevices"        "off"
         option  "AllowEmptyInput"       "off"

Best regards


   - (2^(N-1))

More information about the freebsd-questions mailing list