ndis interface doesn't show up (intel 5300)

Michal ml at infosec.pl
Wed Sep 30 20:48:59 UTC 2009


I'm struggling to get Intel 5300 wireless mini pci-e card working on 
FreeBSD 8.0-RC1 (amd64, both GENERIC and my custom kernel).
I get no error messages. Kernel module builds and loads fine but then 
ndis interface never shows up.

Here is exactly what I'm doing:
Drivers for XP64 downloaded from intel website. I've tried latest and 
old drivers. Unzipped on FreeBSD.
ndisgen NETw5x64.inf NETw5x64.sys
  This .INF file appears to be ASCII. [return]
  This .SYS file appears to be in Windows(r) PE format. [return]
  Driver file conversion - conversion was successful. [enter]
  Firmware file conversion [enter]
  Kernel module generation
   Generating Makefile... done.
   Building kernel module... done.
   Cleaning up... done.

So NETw5x64_sys.ko has been successfully generated. Note that when it 
asks me for additional firmware files I don't give it any - is that ok?

Then I'm moving this module to /boot/modules and I'm loading it:
  kldload -v NETw5x64_sys.ko
  Loaded NETw5x64_sys.ko, id=8

And that's pretty much it, module get loaded together with nids.ko and 
if_nids.ko but nothing really happens. No additional network interfaces, 
nothing in dmesg output. Tried with debug.ndis=1 and get no additional 

Any ideas, please? Anybody got this card to work on FreeBSD?

"The future is here. It's just not widely distributed yet." -William Gibson

More information about the freebsd-questions mailing list