backups & cloning

Polytropon freebsd at
Wed Sep 30 02:07:55 UTC 2009

On Tue, 29 Sep 2009 21:26:19 -0400, PJ <af.gourmet at> wrote:
> But what does that mean? But ad2s1a has just been newfs'd - so how can
> it be dumped if its been formatted?

When you're working on this low level, triple-check all your
commands. Failure to do so can cause data loss. In the example
you presented, ad1 was the source disk, ad2 the target disk.
You DON'T want to newfs your source disk.

> And what exactly does stdout mean?

This refers to the standard output. In most cases, this is the
terminal, the screen, such as

	# cat /etc/fstab

will write the /etc/fstab to stdout. If you redirect it, for
example by using > or |, you can make stdout a file, or the
input - stdin - for another program.

This is how the dump | restore process works: It leaves out
the "use the tape" or "use the file", but instead directs the
output of dump - the dump itself - to the restore program as
input to be restored.

> What is dump doing? outputting what to where exactly?

The dump program is outputting a dump of the specified partition
to the standard output, which in this case is directly trans-
mitted to the restore program, which "picks it up" and processes
it = restores it.

> I don't see it or
> should I say, understand this at all.

Have a look at the command line again, simplified:

	# dump -0 -f - /dev/ad0s1a | restore -r -f -

Run the dump program, do a full backup of the 1st partition of
the 1st slice of the 1st disk, write this dump to the standard
output, pipe this output to the restore program, do a full
restore, read the dump to be restored from standard input.

> and then the restore is from what
> to where?

The restore program gets the dump to be restored from the standard
input - remember, that's the output of the dump program - and
writes it to the current working directory. That's the reason
why you should always check with

	# pwd

in which directory you're currently located, because that will
be the place where the restored data will appear.

> "write error 10 blocks into volume 1
> do you want to restart:"

Could you present the command you're actually using, especially
with where you issued it from?

> The first time I tried with -L the error was 20 blocks...
> Both the slices for dump from and to are same size (2gb) and certainly
> not full by a long shot ( if I reccall correctly, only about 14% is used)

I'm not sure where you put the dump file. "Write error" seems
to indicate one of the following problems:
	a) The snapshot cannot be created.
	b) The dump file cannot be created.

> And what's this about a snapshot? AFAIK, I'm not making a snapshot;
> anyway, there is no long pause except for the dumb look on my face upon
> seeing these messages.

Check "man dump" and search for the -L option. The dump program,
in order to obtain a dump from a file system that's currently in
use, will need to make a snapshot because it cannot handle data
that is changing. So it will dump the data with the state of the
snapshot, allowing the file system to be altered afterwards.

> As it is, I am currently erasing the brand new 500gb disk on which I
> want to restore.


> Things started out really bad... don't u;nderstand what is going on.

Polite question: Have you read the manpages and the section in the

> I
> installed a minimal 7.2, booted up and turned to another computer to do
> some serious work. About 2 hours and 49 minutes later I notice messages
> on the 7.2 about a page fault or something like that and then the system
> reboots.

This often indicates a hardware problem...

> Obviously with errors... but then I reboot again and it comes
> up... I tried som copying from another disk and ended up with the disk
> all screwed up...

How that?

> yet the Seagate Seatools for Dos doesnt find any
> errors on it;

There's smartmontools (program: smartctl) for FreeBSD in the ports.
It can check various errors of modern hard disks.

> Partition magic found an error but couldn't fix it, so now
> Im wiping the whole thing and will try to reinstall tomorrow. Doesn't
> make sense.

What error was this?

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list