Help with NAT

Steve Bertrand steve at
Sat Sep 19 00:18:14 UTC 2009

Scott Elgram wrote:
> Hello,
>             I am at my wits end with this one.  I have set up a box to use
> of firewall/nat.  However, during the setup I pointed set net to do a port
> redirect of port 6502 to port 80 of my development web server.  Everything
> worked fine so I deployed my new box onto a live IP and tested it again with
> the same redirect to my dev server.  Still, everything works fine so I
> changed /etc/natd.conf to point to my production web server and it won't
> work.  I have tried everything that I can think of to narrow down this issue
> but I just can't figure it out.  I pointed everything back to my dev server
> and it's still working.  I changed the dev servers IP and changed nat to
> point to the new IP and it still works.  It would see that nat will work
> only with my dev server and no other computer.
> Can anyone offer any suggestions, I'm sure I'm missing something basic.

On the production server, after you've got things pointed to it:

# tcpdump -n -i em0 port 80

...where em0 is the interface.

Send a request through from the outside, and verify that you can see the
HTTP request come in to the production box, and go back out again. It
should look like the following. Note that these are v6 addrs not v4, but
the result is the same. In the first packet, 5 -> b6 is request in, and
b6 -> 5 is response back. You 'should' see the same result, but with
your v4 addresses instead.

pearl# tcpdump -n -i em0 port 80

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on re0, link-type EN10MB (Ethernet), capture size 96 bytes
20:09:52.912361 IP6 2607:f118::5.1752 > 2607:f118::b6.80: S
3408461679:3408461679(0) win 16384 <mss 1440>

20:09:52.912425 IP6 2607:f118::b6.80 > 2607:f118::5.1752: S
1781312333:1781312333(0) ack 3408461680 win 65535 <mss 1440>

...whether you see the packets come in or not, post back with your findings.

Do you perhaps have to 'restart' natd in order to release any sort of

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3233 bytes
Desc: S/MIME Cryptographic Signature
Url :

More information about the freebsd-questions mailing list