What invokes cricket on FreeBSD

stan stanb at panix.com
Thu Sep 3 13:22:58 UTC 2009

On Thu, Sep 03, 2009 at 01:43:15PM +0100, Matthew Seaman wrote:
> stan wrote:
> > On Thu, Sep 03, 2009 at 07:48:57AM -0400, stan wrote:
> >> I have inherited a system that uses Cricket on FreeBSD to do some data
> >> collection. I have set this up myself in the distnat past, but this time I
> >> asked a contractor to set it up. I no longer have access to this
> >> contractor, and the toher day, we shut down the system this was running on,
> >> and when we rebooted the system, cricket id not resume collecting data.
> >>
> >> I don't see anyhting in /usr/local/etc/rc.d to start it up, nor do I see
> >> anything in /etc/crontag. I don't seen any processes owned by cricket
> >> running.
> >>
> >> In FreeBSD, how is this process noramally invoked?
> > 
> > Sorry to reply to my own message, but I have more data. I did find 
> > 
> > -rw-------  1 root  wheel  288 Jan 12  2009 /var/cron/tabs/cricke
> > 
> > Which is, I am failry certain, what is _intended_ to invoke the cricket
> > process. However, acording to the cricket logs, the last time I have an
> > entry is Aug 29th, which was when the machine was shut down. So, I decided
> > to try running this command by hand. Now, to do so I need to be the cricket
> > user, so I tried to su - cricket. I was told that this user was not
> > avaialble. Looking in /etc/passwd. I found that this users shell was listed
> > as /usr/sbin/nologin. I edited /etc/paswd to change this to /nin/sh, but I
> > still get the smae error message when I try to su to that user.
> > 
> > What do I need to change to be able to su to this suer, and might this be
> > the reason tha it's crontab entry is notbeing run?
> Try:
>    # su -m cricket
> although the best way to examine and/or modify that user's crontab
> is:
>    # crontab -e -u cricket

OK, I was able to execute the cricket collector caoomand bu using the su -
format, and it ran corectly. 

Cany anyone sugest what to check to see why cron is not executing this
command? I see no evidence of it's running in either the cricket logs' or
cron's logs.


One of the main causes of the fall of the roman empire was that, lacking
zero, they had no way to indicate successful termination of their C

More information about the freebsd-questions mailing list