What invokes cricket on FreeBSD

Jerry gesbbb at yahoo.com
Thu Sep 3 12:57:01 UTC 2009

On Thu, 3 Sep 2009 08:25:32 -0400
stan <stanb at panix.com> wrote:

> On Thu, Sep 03, 2009 at 07:48:57AM -0400, stan wrote:
> > I have inherited a system that uses Cricket on FreeBSD to do some
> > data collection. I have set this up myself in the distnat past, but
> > this time I asked a contractor to set it up. I no longer have
> > access to this contractor, and the toher day, we shut down the
> > system this was running on, and when we rebooted the system,
> > cricket id not resume collecting data.
> > 
> > I don't see anyhting in /usr/local/etc/rc.d to start it up, nor do
> > I see anything in /etc/crontag. I don't seen any processes owned by
> > cricket running.
> > 
> > In FreeBSD, how is this process noramally invoked?
> Sorry to reply to my own message, but I have more data. I did find 
> -rw-------  1 root  wheel  288 Jan 12  2009 /var/cron/tabs/cricke
> Which is, I am failry certain, what is _intended_ to invoke the
> cricket process. However, acording to the cricket logs, the last time
> I have an entry is Aug 29th, which was when the machine was shut
> down. So, I decided to try running this command by hand. Now, to do
> so I need to be the cricket user, so I tried to su - cricket. I was
> told that this user was not avaialble. Looking in /etc/passwd. I
> found that this users shell was listed as /usr/sbin/nologin. I
> edited /etc/paswd to change this to /nin/sh, but I still get the smae
> error message when I try to su to that user.
> What do I need to change to be able to su to this suer, and might
> this be the reason tha it's crontab entry is notbeing run?

There is no native port for Cricket on FreeBSD; however, I did find
this URL: http://cricket.sourceforge.net/support/doc/beginner.html

Perhaps if might be of some assistance.

gesbbb at yahoo.com

If you sow your wild oats, hope for a crop failure.

More information about the freebsd-questions mailing list