I REPEAT: maxima can not be built, because gnuplot fails on download

Henry Olyer henry.olyer at gmail.com
Wed Oct 21 09:38:27 UTC 2009

Dear Dan:
I don't want to cause people to jump up and down, but one fact I am
absolutely certain of!, is the following;

Take a hard-drive you can write on, burn a copy of FBSD 7.2 onto a CD, and
do the basic install.  Then, when the base system is up, run sysinstall and
do a "Configure" followed by "Packages".  Then go to "math" and select

Then watch.

Gnuplot, a dependency of maxima will fail.  And thus without using the "-f"
flag (as part of a PKG_ADD command,) you can not load a recent copy of
Maxima on FreeBSD.

This is the case not only for 7.2, but it's been true since at least version

And Gnuplot seems to be missing something called PDFlib -- it may have been
redacted by someone who decided that it wasn't supposed to be public, I
don't know.  But notice I am describing two problems.  One, an install of
Maxima fails using the package method, because Gnuplot doesn't install, and
also, using the ports tree, (see, I'm not talking about a package anymore;)
gnuplot fails to install because the PDFlib ports support file can not be

Oddly, the package install failure, while it names gnuplot, doesn't
correctly identify the problem.  On several systems on which I've tried to
do the maxima install, the error message identifies the problem as an I/O
error.  Only when I attempt the ports-install does the problem show up
correctly, that gnuplot depends on PDFlib, which can not be found.

Obviously I run maxima without gnuplot graphics.  I just had to learn the
work-around, not a big deal...

I look at it this way...  For me, getting maxima up on FreeBSD has taught me
a lot about how FBSD is organized.  But really, someone should take the time
to make this a solved problem.  I can make gnuplot work, but I don't have
the authority to change the package content.

A similar problem exists with clusterit.  Most of the commands work just
fine.  But the semaphore control, (called "guards" in clusterit,) don't
lock.  They simply don't.  The program probably works fine in Linux.  But
myself and a friend, who have about 85 years of programming experience
couldn't make it work.  We scrapped it and wrote our own tool to do this.

I love FreeBSD and I continue to be very impressed with the quality of this
OS, not just the core, not just the documentation, not just the
applications, simply, it is truly a remarkable 'product'.  The people who
have contributed to making this work should know that they have really

And I use FBSD heavily -- in fact I and a couple of friends put together a
cluster of machines and we never saw any other OS as a good choice.  These
two problems are all I have;  So you see, I'm not unhappy.

On Wed, Oct 21, 2009 at 1:06 AM, Dan Nelson <dnelson at allantgroup.com> wrote:

> In the last episode (Oct 20), Henry Olyer said:
> > I have a fix for gnuplot;
> > How do I get it reviewed and perhaps incorporated into FreeBSD?  Notice,
> I
> > am not saying gnuplot is bad, it just doesn't work, not since at least
> > 6.1.  Earlier than that I don't know.
> What errors are you getting?  Portsmon says that gnuplot builds fine on
> all three branches:
>  http://portsmon.freebsd.org/portoverview.py?category=&portname=gnuplot
> If you have a patch, send a PR:
> http://www.freebsd.org/doc/en/articles/problem-reports/article.html
> --
>        Dan Nelson
>        dnelson at allantgroup.com

More information about the freebsd-questions mailing list