PJ af.gourmet at
Wed Oct 14 21:22:15 UTC 2009

I have not had a chance to thank you for your very helpful suggestions.
I have tried to follow them as well as possible and I cerainly am
grateful for your input.
It has taken me some time to prepare for a cloning of an existing 7.2 sytem.
Now that I have everything running smoothly with all the proggies &
configurations the way I want them, I tried (notice - tried) to clone
the system.
Here's the setup:
FBSD 7.2 on ad4 and same on ad12.
First, running on ad4, I tried to dump & restore each partition directly:
ad12s1a to da0s1a (usb sata disk).  No go. I had set it up originally
with livefs, minimal; then redid it all with fdisk, bsdlabel and nwfs; then
dump -0af - /dev/ad12s1a | restore -rf - /dev/da0s1a
--- got error messages about not being a tape device. Great.
Next, I tried with another usb/sata disk on da0... dumped to files (dump
went w/out problems) ... mounted da0 partitions 1 x 1 to /mnt, cd'd to
/mnt and did
restore -rf file.
Only the ad12s1f(usr) restore gave long list of "unable to create file
or link or something like that".
When I then installed the restored disk to another computer (identical
except for CPU (3gb instead of 2.4gb), booted from the restored disk and
saw that it was trying to boot from ad12s1a which doesn't exist on the
new machine. uh...oh...
Somehow I think I may not have understood something.
Perhaps I should install the disk directly in the dump/restore machine
and try again.
Oh, yes, another sign from the gods... when restoring to a partition
just newfsed there is a warning that .snap is already installed... now
what on earth or moon is that?
I will try again... and try to document more clearly... :-(

More information about the freebsd-questions mailing list