Upgrade 7.2-RELEASE to 8.0-RC1 problem

Alexandre axelbsd at ymail.com
Wed Oct 14 16:29:01 UTC 2009


I have tried to upgrade my laptop system from 7.2-RELEASE to 8.0-RC1 using
the freebsd-update method.
I have ran the following commands :

# freebsd-update -r 8.0-RC1 upgrade
# freebsd-update install
# nextboot -k GENERIC
# shutdown -r now
# freebsd-update install
# portmaster -adf

Then portmaster program does not recognize by the system.
# rehash
Does not have effect.
Then I have rebooted the machine one more time and I have select the boot
option 6 and type


Now the system don't want to boot correctly because it can't do fsck_ufs on

I have download and burn the livefs 8.0-RC1 iso and use the fixit part.
fsck_ufs /dev/ad0s1a do the steps correctly then I tried to boot on my
GENERIC patched local kernel (using boot option 6 like described above) but
I always got the same error.

I have noticed that I have got these messages before the boot menu
Boot: syntax error on file /boot/device.hints
Boot: syntax error on file /boot/loader.conf

Also, I tried this :
(escape to loader prompt) *
*# boot -s >> OK - It boot on 7.2 kernel
# adjkerntz -i >> OK
# swapon -a >> swapon: not found
# fsck -p >> fsck: exec fsck_ufs for /dev/ad0s1a in /sbin:/usr/sbin: no such
file or directory
# mount -u / >> OK
# mount -va >> OK

If I rebooted like this method
(escape to loader prompt)
# boot GENERIC

It boot on 8.0-RC1 kernel, but the only command that doesn't passed is
# swapon -a >> swapon: not found

After the command :
# fsck -p
I can access to the login prompt. But when I tried to login with root or
another user, I got the following error :
login: login: could not determine audit condition

Can you help me to repair the errors ?

Thanks for your help.

More information about the freebsd-questions mailing list