Broadcom bce interface problems

Brian McCann bjmccann at
Tue Oct 13 22:46:42 UTC 2009

On Tue, Oct 13, 2009 at 8:41 AM, Steve Bertrand <steve at> wrote:
> Brian McCann wrote:
>> I'm having problems with the bce interface on a FreeBSD 7.2 install, using
>> an IBM BladeCenter HS21 machine.  The machine uses the NetXtreme II card.
>>  The really strange thing here is, the switch shows a link, but the card
>> shows no carrier in the setup.  It started working for a few seconds at one
>> point when I reset the switch (at least, I think that's what I did), and it
>> detected 1000BaseSX as the media and showed a status of active, but promptly
>> went away.  If I try setting the media type manually, that doesn't appear to
>> work.
>> Has anyone seen this or have any ideas?
> Try forcing the interface to 'up':
> # ifconfig bce0 up
> If that works, add it to the /etc/rc.conf:
> # echo 'ifconfig_bce0="up"' >> /etc/rc.conf
> Steve

Thanks for the suggestion.  I just tried it, but still get "no
carrier" for the status.


Brian McCann

"I don't have to take this abuse from you -- I've got hundreds of
people waiting to abuse me."
                -- Bill Murray, "Ghostbusters"

More information about the freebsd-questions mailing list