cdrecord returning inappropriate ioctl

David LeCount snailboy1 at
Sun Oct 11 14:18:43 UTC 2009

I'm not sure when this started. I thought it might have started when I added my RAID controller which has SCSI emulation too, but the error still occurs when I remove it. So I'm guessing it started when I upgraded to 8.0 RC1 from 7 stable.

I have a Pioneer DVD-RW. Burncd doesn't support it so I've always used cdrecord, but a few days ago, it gave me this error:

[root at bahamut ~]# cdrecord -scanbus
Cdrecord-Clone 2.01 (i386-unknown-freebsd7.0) Copyright (C) 1995-2004 Jörg Schilling
cdrecord: Inappropriate ioctl for device. CAMIOCOMMAND ioctl failed. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Camcontrol works fine.

[root at bahamut ~]# camcontrol devlist
<WDC WD5000AADS-00S9B 0A01>        at scbus0 target 0 lun 0 (pass0)
<WDC WD5000AADS-00S9B 0A01>        at scbus0 target 1 lun 0 (pass1)
<WDC WD5000AADS-00S9B 0A01>        at scbus0 target 2 lun 0 (pass2)
<PIONEER DVD-RW  DVR-110D 1.11>    at scbus3 target 0 lun 0 (cd0,pass3)

I tried using cdrecord with lun 3,0,0 as reported by camcontrol and got the same error as with -scanbus. I'm thinking this is a bug with either cdrecord or the kernel, but I thought I'd check here first to make sure I haven't missed something.


More information about the freebsd-questions mailing list