xorg-server package update on 7.2-STABLE

Obrien, John W john.w.obrien at lmco.com
Fri Oct 9 13:36:02 UTC 2009

Good morning,

The problem I'm having is that "startx" gives a garbage-filled screen and locks up the console. When I run it through ssh from another computer I can see that it complains:

/libexec/ld-elf.so.1: /usr/local/bin/X: Undefined symbol "shmctl"

before dying and leaving the main display buggered up. Rebooting the computer is the only way I've found to un-bugger it.


Recently installed fresh i386 7.2-RELEASE, and subsequently had X working with the "intel" driver. I ran "portupgrade -aPP" two days ago using packages-7-stable and immediately thereafter experienced the symptoms described above. I see nothing related in /usr/ports/UPDATING since the release date of 7.2. The closest things that turned up Googling variations of the error message has turned up were

http://forums.freebsd.org/showthread.php?t=6661 and http://forums.freebsd.org/showthread.php?t=7464

which strike me as "close but no cigar."

This is close to the hairy edge of my competence, but I tried comparing the dynamic symbol tables of the relevant files with the following results

# objdump -T /usr/local/bin/Xorg | grep shmctl
000000000        DF        *UND*   000000000        FBSD_1.1         shmctl
# objdump -T /lib/libc.so.7
00045f64           W         DF        .text      000000000        FBSD_1.0         shmctl
# pkg_info -W /usr/loca/bin/Xorg
/usr/local/bin/Xorg was installed by package xorg-server-1.6.1,1

I interpret this to suggest that the updated Xorg was linked to a different version of the C library and is looking for a version of the symbol that doesn't exist, though perhaps I'm misreading


My specific questions are:

- Am I on the right track with my diagnostic steps or is this the wrong rabbit hole?
- Is this more likely a bug (xorg-server from 7-STABLE shouldn't break ABI with 7.2-RELEASE) or operator error (missing or incorrect update step)?
- I would prefer to maintain my system using pre-compiled packages only. Is that feasible, and if so does it come with restrictions that I may have already violated?

Any pointers would be appreciated and a solution would be greatly appreciated. Please let me know if there are potentially-relevant details I've omitted.


More information about the freebsd-questions mailing list