Xorg mouse not working after upgrade (console mouse works)

Warren Block wblock at wonkity.com
Sun Oct 4 22:45:16 UTC 2009

On Sun, 4 Oct 2009, Nerius Landys wrote:

> I had everything (Xorg + console mouse) working perfectly on my 6.3
> system with slightly outdated ports.  Now I upgraded to 6.4 and the
> latest ports.  I am getting some strange behavior with respect to the
> mouse.  I did adjust some lines of rc.conf in the process of trying to
> debug the problem (moused used to be enabled and now it's not).
> I have a run-of-the-mill USB mouse hooked up.
> In the console (before I type "startx"), I am able to move the mouse
> cursor and copy+paste just fine in the console.  My rc.conf looks like
> this (surprisingly, moused is NOT enalbed, and the console mouse DOES

But if you check with ps, you'll find moused is running anyway.  It gets 
started so that hotplugging USB mice works.  See 
moused_nondefault_enable in rc.conf(5).  Since you have a USB mouse, you 
might as well add moused_enable="YES" to rc.conf.

>  defaultrouter=""
>  hostname="tweety.i"
>  ifconfig_em0="inet  netmask"
>  sshd_enable="YES"
>  usbd_enable="YES"
>  # added by xorg-libraries port
>  local_startup="/usr/local/etc/rc.d"
>  hald_enable="YES"
>  dbus_enable="YES"
> When I "startx", the mouse cursor won't move.  I have nothing 
> currently in /etc/X11/xorg.conf (it's missing).

Make sure that there isn't an xorg.conf somewhere else that's being 
used.  /var/log/Xorg.0.log will show for sure:

(==) Using config file: "/usr/local/lib/X11/xorg.conf"

> I tried "Xorg -configure" and copying the output of that to 
> /etc/X11/xorg.conf, but no change in behavior.

That produces an increasingly outdated config file.

> I am also trying to add
>  moused_enable="YES"
> to my rc.conf.  Then when I try to start moused, I get the following error:
>  Starting default moused:moused: unable to open /dev/psm0: No such
> file or directory

Remember that moused is already running, and you may have to kill it 
before trying to re-run it with /etc/rc.d/moused.  Running 6.4 might 
make a difference, too; I don't know.

> Had a look in /etc/defaults/rc.conf, but cannot decide on what to
> change in /etc/rc.conf to make X work.
> I really see no point in starting moused if the console mouse is
> already working, however.   Is that correct?
> When I generated the xorg.conf with "Xorg -configure", I did see this
> section in the xorg.conf:
>  Section "InputDevice"
>          Identifier  "Mouse0"
>          Driver      "mouse"
>          Option      "Protocol" "auto"
>          Option      "Device" "/dev/sysmouse"
>          Option      "ZAxisMapping" "4 5 6 7"
>  EndSection
> Any ideas on how to get mouse to work in X?  I had a good look at the
> Handbook but everything I tried there did not fix the problem.

Enable hal and dbus (and moused) in rc.conf.  Make sure all are started 
and continue running; hal erroring out can be annoying.

If you were running without an xorg.conf before, that should be enough.

-Warren Block * Rapid City, South Dakota USA

More information about the freebsd-questions mailing list