problem with Olympus USB camera on 8.0 RELEASE

Mike Clarke jmc-freebsd2 at
Mon Nov 30 13:04:16 UTC 2009

On Sunday 29 November 2009, krad wrote:

> 2009/11/28 Mike Clarke <jmc-freebsd2 at>
> > The camera in question is an Olympus C-2040Z, I've had no problems
> > using it with 6.4. I tried rev. 7 some time ago but plugging the
> > camera in always caused a panic and crash so I stayed with 6.4. Now
> > that 8.0 is out I'd like to move on and the good news is that with
> > 8.0 I can connect the camera without a panic but the bad news is
> > that although the system detects the camera I'm not able to access
> > it. On plugging in the camera I see the following console messages:
> >
> > ugen0.2: <OLYMPUS> at usbus0
> > umass0: <OLYMPUS C-2040ZOOM, class 0/0, rev 1.10/1.00, addr 2> on
> > usbus0 umass0:  SCSI over (unknown 0x00); quirks = 0x0100
> > umass0: could not setup required transfers, USB_ERR_INVAL
> > device_attach: umass0 attach returned 6


>  try connecting it via a powerd usb hub

Unfortunately I don't have one, perhaps my simplest solution would be to 
get a USB card reader and bypass the camera's USB system.

>  or forcing the usb speed down to version 1

I tried this by building a test kernel without ehci but that had no 
effect and the camera was still inaccessible..

Mike Clarke

More information about the freebsd-questions mailing list