X11's tcp port

Chuck Robey chuckr at telenix.org
Wed Nov 25 19:27:23 UTC 2009

Hash: SHA1

I've got to be doing something wierd, for this not to work ... I wanted to kick
off a app on a 2nd machine of mine, and have it display on my main FreeBSD
machine, but it won't work.  I know all the security things, I know I had xhost
and DISPLAY correct, so I went to check netstat for the ip port 6000 being open,
but netstat shows me no  such port.

I usually, to defeat the "nolisten" options usually set on, edit my startx file
to remove any such line.  You just search for "nolisten tcp" or some subset of
that (tcp might get set separately) but as I expected, I'd edited that line out
ages ago, when I last wanted to display a foreign app onto my FreeBSD X11
screen.  However, no matter how I tried to start my X, I can't seem to provoke
netstat to show my ip port 6000.  I tried running my ordinay startxfce4, I tried
kde3, I even tried twm, I just can't get IP port 6000.  You know that without
that port,  you can't run remote X applications.

This used to work.  Any idea why it's stopped working for me?
Version: GnuPG v1.4.9 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the freebsd-questions mailing list