WiFi interface - scanning ssid

Samuel Martín Moro faust64 at gmail.com
Mon Nov 23 13:37:58 UTC 2009

that may help:

my uname:
FreeBSD devel.axis.fr 7.2-RELEASE FreeBSD 7.2-RELEASE #0: Wed Oct 14
15:26:50 CEST 2009     root at h2g2.axis.fr:/usr/obj/usr/src/sys/GENERIC  i386

in rc.conf:
hostapd/dhcpd/ifconfig_rum0 are commented

wlan_xauth is loaded

~# ifconfig rum0 down
~# ifconfig rum0 delete
ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address
~# ifconfig rum0 destroy
ifconfig: SIOCIFDESTROY: Invalid argument
~# ifconfig rum0
rum0: flags=108802<BROADCAST,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
        ether 00:18:1a:0c:65:2f
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
        status: no carrier
        ssid 1921680452 channel 2 (2417 Mhz 11g)
        authmode AUTO privacy OFF txpower 50 scanvalid 60 bgscan
        bgscanintvl 300 bgscanidle 250 roam:rssi11g 7 roam:rate11g 5
        protmode CTS dtimperiod 1

before, my card was listed by pciconf (but isn't anymore), as noneX
now, I can view it using usbdevs:
port 4 addr 2: high speed, power 300 mA, config 1, 802.11 bg WLAN(0x2573),
Ralink(0x148f), rev 0.01

I used to test WIFI with two different chipset.
I generated the first driver using ndisgen, and compiled back the kernel
(adding some lines into headers) to deal with the second one.
I don't remember which one I use here. But my problem might come from a bad
driver. (but most likely: PEBKAC)

Thanks for your help

Samuel Martín Moro
{EPITECH.} tek4

| "Nobody wants to say how this works.  |
|  Maybe nobody knows ..."              |
|                       Xorg.conf(5)    |

On Mon, Nov 23, 2009 at 12:33 PM, Samuel Martín Moro <faust64 at gmail.com>wrote:

> Hi
> I'm trying to list ssid neighborhood.
> doing ifconfig rum0 scan or ifconfig rum0 list scan, there isn't any
> returned row.
> it perfectly works a few days ago, when I was working on a script to
> configure WIFI interfaces as client.
> more recently, I tried to do a script to configure WIFI interfaces as
> access points. since that, all my scan/list scan are empty.
> by the way, while testing, I wasn't able to reset interface configuration
> (and maybe it's my list/scan) problem.
> I tried with delete, ... It still keeps the old conf, when I'ld like to
> drop it. How should I do ?
> Thanks!
> Samuel Martín Moro
> CamTrace
> {EPITECH.} tek4
> | "Nobody wants to say how this works.  |
> |  Maybe nobody knows ..."              |
> |                       Xorg.conf(5)    |

More information about the freebsd-questions mailing list