[Solved] Do permissions take time to take effect?

James Phillips anti_spam256 at yahoo.ca
Wed Nov 18 17:57:59 UTC 2009

--- On Wed, 11/18/09, Dan Nelson <dnelson at allantgroup.com> wrote:

> In the last episode (Nov 17), James
> Phillips said:
> > I wanted to create a shared directory writable by all
> users. When it
> > initially failed, I assumed there may be a blanket ban
> on writing to
> > directories owned by root.  Today, I was able to
> write to the root-owned
> > "Share" directory.  However, when I re-created
> the directory owned by a
> > special-purpose "Share" user, I ran into the same
> problem again.
> You are probably in the "users" group.  Running either
> the "groups" or "id"
> command will say for sure.

Yes, I was using the "cd" and "pwd" combination as a poor replacement.
It is possible to re-assign the "home" directory.

$ groups
james Share
$ id
uid=1001(james) gid=1001(james) groups=1001(james),1003(Share)

(I have since deleted the "users" group: it is a Debian thing, and I had NIS set up to NOT export the membership information)
> If you are currently either the "james" or "backup" user,
> and added the
> Share group membership on another tty, then you may need to
> log out and back
> in for the system to assign your new group membership to
> your session. 
> Filesystem permissions take effect immediately, but group
> memberships are
> assigned once, at login.

This here was the problem. I was not logging out after the changes. However, I am in the habit of logging out at the end of the day. As a result, I would get the updated permissions when I log in the next day.

Thank-you for your help,

James Phillips

Looking for the perfect gift? Give the gift of Flickr! 


More information about the freebsd-questions mailing list