install.cfg scripting issue

Frank Shute frank at
Sat Nov 7 15:41:18 UTC 2009

On Fri, Nov 06, 2009 at 11:31:39AM -0800, Jason wrote:
> Hi,
> I am having a heck of a time getting an automated installation to get a
> couple of commands done, and was wondering if anyone would be able to offer
> any assistance.
> Everything works, but post does not. I know we will more than likely move to
> a post pkg for configuration, but due to the time-frame to deliver, what
> follows below will suit needs just fine.
> command='echo sshd_enable="YES" >> /etc/rc.conf.local'
> system
> command=cp /usr/share/zoneinfo/America/Los_Angeles /etc/localtime
> system
> command=/sbin/reboot
> system
> I've tried the first command, and it fails, with a "command not found," and
> I have yet to get past those command to the last commands. I have been using
> single ticks, and double-quotes, but nothing is seeming to work. In
> addition to this, I have also escaped the quotes.
> Any help is much appreciated.
> Thanks,
> Jason

I'm not familiar with install.cfg but have you tried using the full
path for your command? E.g:

command='/bin/echo sshd_enable=\"YES\" >> /etc/rc.conf.local'

Ditto with your other commands.




 Contact info:

More information about the freebsd-questions mailing list