dhcpd related issue - not giving up

Dánielisz László laszlo_danielisz at yahoo.com
Mon Nov 2 19:49:16 UTC 2009

Thank you for your advice, I tried to restart dhcpd a few times and I also tried about 10+ dhcpd.conf-s.
Right now it's reinstalling the port.

From: Tim Judd <tajudd at gmail.com>
To: Dánielisz László <laszlo_danielisz at yahoo.com>
Cc: freebsd-questions at freebsd.org
Sent: Mon, November 2, 2009 5:16:58 PM
Subject: Re: dhcpd related issue - not giving up

On 11/2/09, Dánielisz László <laszlo_danielisz at yahoo.com> wrote:
> I tried about 10 conf, here is the actual one:
> # cat /usr/local/etc/dhcpd.conf
> authoritative;
> ddns-update-style none;
> subnet netmask {
>   option routers;
> pool {
>            option domain-name-servers cns01.hdsnet.hu;
>            max-lease-time 300;
>            range;
>            allow unknown-clients;
>          }
> }

It looks awkward...
  I don't recall ever seeing a pool inside a subnet declaration like this.
A subnet declaration can use all the declaration in your pool.

Pure curiousity, because I am not looking up the config syntax..
comment out (or delete) the pool { and } lines only.  which bring the
statements to the subnet clause.

restart dhcpd, and retry

IIRC, pools are only useful if you have two pool definitions.

thanks...  hope this works.
freebsd-questions at freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"


More information about the freebsd-questions mailing list