nvidia-drivers crash computer on X start

rasz raszobbi at gmail.com
Sat Mar 28 09:35:03 PDT 2009

Anders Holmström wrote:
>> did you try
>> Option "AllowEmptyInput" "off"
>> in Serverlayout section under screen, keyboard, mouse?
> I was  told by a guy on the nvnews.net forums that I should put
> machdep.disable_mtrrs=1 in my /boot/loader.conf. Apparently he had had
> the same problem and he said it was because he had more than 2 gigs of
> ram. He had solved it by that setting, and later by simply removing
> the ram. I have 4 gigs, and the setting did work for me. HOWEVER, now
> that I startx it's impossible to move the mouse/use the keyboard. It
> also complaints about not being able to locate driver "kbd" and driver
> "mouse", plus mentions AllowEmptyInput as the culprit. I tried
> disabling it but it in xorg.conf, but didn't help on the input device
> issue. X still started though.
> I didn't think the two were related, but based on your post I guess
> they are. You could (or somebody else) possibly enlighten me a bit
> more about the relationship, or point me in the right direction? man
> xorg.conf didn't give much info.
i am not sure about the machdep setting there so i cc'd the mailing list 
maybe someone else can help you there.
about the AllowEmptyInput however, there is some info in ports/UPDATING 
round about when xorg was updated because I
am not sure if you said you disabled the mouse from xorg config instead 
of moused in etc/rc.conf ( if that is what you said).
i have moused_enable="NO" in etc/rc.conf and add Option 
"AllowEmptyInput" "off" in xorg.conf.new right after a Xorg -configure.
also, i think you have to test cuz ppl get different setting to work 
depending their hardware, but i have had similar problem as you
with moused enabled and AllowEm...added. ( i have only 1gb memory fyi)

More information about the freebsd-questions mailing list