3ware 8006-2lp hang with ACPI enabled on fbsd-6.4

Artem Kuchin matrix at itlegion.ru
Wed Mar 25 04:38:32 PDT 2009


I have something strange here.
I had a pretty old (5 y.o) network server with mirror raid on 3WARE 8006-2LP
running FreeBSD 5.3. memory or mb started to fail
periodically, so the server was upgraded to Asus P5Q MB. Everything was 
Then i decided to upgrade to 6.4-STABLE. After upgrade the machines just 
locked up
after kernel boot is complete and daemons started to load. I have tried 
many times: sometimes
i see PCI parity error from twe driver. Something i don't see any 
message at all, the machines just
I tried changing  pci  slot, playing with BIOS settings - no luck.
Then i just booted with ACPI disables and everything worked fine!
I tried disabling parts of ACPI with debug.acpi loader options, but if i 
"bus" and "pci"  the loader cannot load the kernel and all other options 
do not help.
The firmware on the raid controller is the latest available (dec 2007).

Can anyone explain, why everything worked fine on 5.4 and locks up on 6.4?

I am upgrading the box to 7.1-STABLE now via cvs.


More information about the freebsd-questions mailing list